Building JSure on Ubuntu

I needed to do the following additional steps to get JSure: The Javascript Checker (Version 1.0.0 from http://www.jsure.org) to build on Ubuntu (8.04, hardy).

  1. I did not have ocaml installed — I need to run “aptitude install ocaml“.
  2. The build was failing with errors referring “ocamlopt.opt” — I had to modify all references to “ocamlopt.opt“, “ocaml.opt” and “ocamldep.opt” to remove the “.opt” in the Aurochs build file myocamlbuild.ml.
  3. The JSure build was giving me “/usr/bin/ld: cannot find -lgdbm_compat” errors — I had to make softlinks in /usr/lib to the version specific libraries that linker/loader was complaining about (ln -s libgdbm_compat.so.3.0.0 libgdbm_compat.so)

The other instructions at the JSure web-site also need be followed.

Share

One thought on “Building JSure on Ubuntu”

  1. Thanks for the tips!

    I fixed item 3 issue with
    sudo apt-get install libgdbm-dev

    (Running portable-Ubuntu TRES, a colinux “port” of Ubuntu-9.10 to Windows)

Leave a Reply

Your email address will not be published. Required fields are marked *